Skip to main content

Unity

Prerequisites

  • Unity LTS 2019 or above
  • For Android
    • Minimum API Level 21 or above
    • Target API Level 33 or above
    • Gradle 6.7.1 or above (set the Gradle version to 6.7.1 manually if Unity Editor version is lower than 2022.3)
    • If you use Proguard, please refer to the documentation.
  • For iOS
    • iOS 13.0 or above.
    • Xcode 14.3 or above
    • Cocoapods 1.10.0 or above

Installation

Download the SDK

Download the latest SDK here.

To build for iOS, you need to update your iOS resolver settings under External Dependency Manager -> iOS Resolver:

unity_iOSResolver.png

Import the Unity Package

Open your Unity project and import the Unity package. The files will automatically populate as shown below.

unity_import_plugin.png

The MAS Unity plugin is built for Android and iOS platforms. After integration, please test ads on Android and/or iOS devices.

Ad Network Manager

Starting from MAS 4.8.10, we have introduced the Ad Network Manager, allowing dynamic addition or removal of ad networks. For more details, please refer to the documentation.

Note: Contact our support team for guidance on removing ad networks without impacting revenue.

Next Steps

Video Tutorial