Skip to main content

Android

Prerequisites

  • Minimum API Level 21 or above.
  • Target API Level 33 or above.
  • compileSdkVersion 33 or above
  • Android Gradle plugin version 4.2.0 or above
  • Gradle 6.7.1 or above.
  • If you use Proguard, please refer to the documentation.

Add the repositories

Add the following repositories to your build.gradle file.

mavenCentral()
maven { url "https://artifact.bytedance.com/repository/pangle" }
maven { url "https://android-sdk.is.com" }
maven { url "https://dl-maven-android.mintegral.com/repository/mbridge_android_sdk_oversea" }
maven { url "https://artifactory.bidmachine.io/bidmachine" }

Import the SDK

Open your app-level build.gradle and add the following dependency.

implementation 'com.yodo1.mas:full:4.12.0'

Next Steps

Video Tutorial